<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard &#8211; NBC 6 South Florida</title>
<meta name='robots' content='max-image-preview:large' />
<link rel="preload" href="https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC 6 South Florida &raquo; Feed" href="https://www.nbcmiami.com/?rss=y" />
<style class="wp-asset-manager nbc-common-css" type="text/css">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</style><style class="wp-asset-manager nbc-global-css" type="text/css">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</style><link rel='stylesheet' id='all-css-0' href='https://www.nbcmiami.com/_static/??-eJzTLy/QzcxLzilNSS3WzyrWz01NyUxMzUnNTc0rQeEU5CRWphbp5qSmJyZX6uVm5uklFxfr6OPTDpRD5sM02efaGpqZmVgaGBiYGgIARLYu2w==' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://www.nbcmiami.com/_static/??-eJydzEsOwiAUheENKa/y6sA4cANugXvhRiKFptC4fTXGDXR8/vPx13rGVkeqg49HWlLnFfDcRxi5VY4lfxfYc4kce+dhGxlLYg4BSFiVZkyS1KSJgC25sk904sfQ2+/CdHRaWCMp6smHiF664zaUhs/OPHljlZnAQ3JCGSNiOmwurY97W/cSNkbGG6UDGDuHSaAkIvWHr8tFWqtnL4V2b7U1fko=' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcmiami.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcmiami.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcmiami.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcmiami.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcmiami.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.5" />
<link rel="canonical" href="https://www.nbcsports.com/bayarea/warriors/steph-curry-dominates-nba-gm-survey-most-clutch-player-best-guard" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcmiami.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcmiami.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F&#038;format=xml" />
        <style>
        .getty.aligncenter {
            text-align: center;
        }
        .getty.alignleft {
            float: none;
            margin-right: 0;
        }
        .getty.alignleft > div {
            float: left;
            margin-right: 5px;
        }
        .getty.alignright {
            float: none;
            margin-left: 0;
        }
        .getty.alignright > div {
            float: right;
            margin-left: 5px;
        }
        </style>
        <style type='text/css'>img#wpstats{display:none}</style>
	<script>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</script><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%); }
</style>
<meta property="og:site_name" content="NBC 6 South Florida" /><meta name="google-site-verification" content="HzcUi6Q6ShKtCzhpQt1Ib8nYsujnP87Ppt6B1_0vOR8" /><meta property="fb:app_id" content="91295312088" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbc6" /><meta name="twitter:creator" content="@nbc6" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/NBC6SouthFlorida" /><meta name="description" content="Steph Curry, the reigning NBA Finals MVP, had his name was all over the annual NBA general manager survey." /><meta property="og:description" content="Steph Curry, the reigning NBA Finals MVP, had his name was all over the annual NBA general manager survey." /><meta name="twitter:description" content="Steph Curry, the reigning NBA Finals MVP, had his name was all over the annual NBA general manager survey." /><meta property="og:title" content="Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard" /><meta name="twitter:title" content="Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard" /><meta name="keywords" content="Golden State Warriors, NBA, Steph Curry" /><meta property="og:url" content="https://www.nbcmiami.com/news/sports/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard/2875720/" /><meta name="twitter:url" content="https://www.nbcmiami.com/news/sports/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard/2875720/" /><meta name="sailthru.title" content="Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard" /><meta name="sailthru.description" content="Steph Curry, the reigning NBA Finals MVP, had his name was all over the annual NBA general manager survey." /><meta name="sailthru.tags" content="Golden State Warriors, NBA, Steph Curry" /><meta name="sailthru.tags" content="Golden State Warriors, NBA, Steph Curry" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-10-04T19:50:25+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcmiami.com/2022/07/steph-curry-night-night-USA_0.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcmiami.com/2022/07/steph-curry-night-night-USA_0.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcmiami.com\/news\/sports\/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard\/2875720\/","headline":"Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard","datePublished":"2022-10-04T19:50:25","dateModified":"2022-10-05T09:38:15","description":"Steph Curry, the reigning NBA Finals MVP, had his name was all over the annual NBA general manager survey.","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Golden State Warriors, NBA, Steph Curry","publisher":{"@type":"Organization","name":"NBC 6 South Florida","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcmiami.com\/wp-content\/uploads\/2022\/05\/amp_square_wtvj.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcmiami.com\/2022\/07\/steph-curry-night-night-USA_0.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcmiami.com\/news\/sports\/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard\/2875720\/","description":"Steph Curry&#8217;s name was all over the annual NBA general manager survey.","duration":"PT01M11S","name":"Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard","thumbnailUrl":"https:\/\/media.nbcmiami.com\/2022\/07\/steph-curry-night-night-USA_0.jpg?quality=85&strip=all&resize=1200%2C675","uploadDate":"2022-10-04T19:50:25"},"author":{"@type":"Person","name":"Tom Dierberger"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcmiami.com/news/sports/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard/2875720/?amp=1"><link rel="icon" href="https://media.nbcmiami.com/2019/09/cropped-NBC_South-Florida.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcmiami.com/2019/09/cropped-NBC_South-Florida.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcmiami.com/2019/09/cropped-NBC_South-Florida.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcmiami.com/2019/09/cropped-NBC_South-Florida.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2875720 single-format-standard station-nbc wtvj has-featured-image has-section-branding short-section-branding">
	<div id="leaderboard" class="leaderboard-ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcmiami.com/">
						<img src="https://media.nbcmiami.com/2019/09/SouthFlorida_On_Dark@3x-1.png?fit=627%2C120&#038;quality=85&#038;strip=all&#038;w=209&#038;h=40" srcset="https://media.nbcmiami.com/2019/09/SouthFlorida_On_Dark@3x-1.png?fit=627%2C120&amp;quality=85&amp;strip=all&amp;w=209&amp;h=40 1x, https://media.nbcmiami.com/2019/09/SouthFlorida_On_Dark@3x-1.png?fit=627%2C120&amp;quality=85&amp;strip=all&amp;w=418&amp;h=80 2x, https://media.nbcmiami.com/2019/09/SouthFlorida_On_Dark@3x-1.png?fit=627%2C120&amp;quality=85&amp;strip=all&amp;w=627&amp;h=120 3x" alt="NBC 6 South Florida" height="40" width="209" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcmiami.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input class="search-form-input" type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-header-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Video" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Responds" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/responds/">Responds</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcmiami.com/newsletters/">Newsletters</a></li>
<a data-lid="TV Listings" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcmiami.com/live/">TV Listings</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcmiami.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Ian Latest" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/tag/hurricane-ian/" class="site-header__trending-nav-item">Ian Latest</a>
					<a data-lid="Parkland Trial" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/news/local/live-updates-parkland-school-shooter-death-penalty-trial/2805624/" class="site-header__trending-nav-item">Parkland Trial</a>
					<a data-lid="Comcast RISE" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/news/local/comcast-rise-applications-open-for-1-million-in-grants-for-south-florida-minority-owned-businesses/2873906/" class="site-header__trending-nav-item">Comcast RISE</a>
					<a data-lid="Migrants" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/tag/migrants/" class="site-header__trending-nav-item">Migrants</a>
					<a data-lid="Inflation" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/tag/inflation/" class="site-header__trending-nav-item">Inflation</a>
					<a data-lid="COVID-19" data-lpos="trending-stories-module" href="/news/coronavirus/" class="site-header__trending-nav-item">COVID-19</a>
					<a data-lid="NBC 6 App" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/news/local/track-the-tropics-with-radar-and-alerts-in-the-nbc-6-app-as-hurricane-season-heats-up/2865306/" class="site-header__trending-nav-item">NBC 6 App</a>
					<a data-lid="Peacock" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/tag/peacock/" class="site-header__trending-nav-item">Peacock</a>
					<a data-lid="Newsletters" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/newsletters/?_osource=ed_npd_nbc_nat_ot_newltrtrending" class="site-header__trending-nav-item">Newsletters</a>
					<a data-lid="NBCLX" data-lpos="trending-stories-module" href="https://www.nbcmiami.com/lx/" class="site-header__trending-nav-item">NBCLX</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="33133">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2875720" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background">
			<img 
				src="https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&#038;quality=85&#038;strip=all&#038;w=400&#038;h=44&#038;crop=1"
									srcset="https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=400&amp;h=44&amp;crop=1 400w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=500&amp;h=56&amp;crop=1 500w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=600&amp;h=67&amp;crop=1 600w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=700&amp;h=78&amp;crop=1 700w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=800&amp;h=89&amp;crop=1 800w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=900&amp;h=100&amp;crop=1 900w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=1000&amp;h=111&amp;crop=1 1000w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=1100&amp;h=122&amp;crop=1 1100w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=1200&amp;h=133&amp;crop=1 1200w, https://media.nbcmiami.com/2019/09/Miami2.png?fit=1440%2C415&amp;quality=85&amp;strip=all&amp;w=1300&amp;h=144&amp;crop=1 1300w"
													sizes="100vw"
								class="hero-background__img" 
				fetchpriority="high" 
			/>
		</div>
	
	
	
			<div class="section-archive-header"><div class="section-archive-header--text-wrap"><a href="/news/sports/"><div class="section-archive-header__category section-archive-header__category--no-desc"><h1>Sports</h1></div></div></a><div id="div-gpt-ad-logo_header" class="section-archive-header__ad gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_header', format: 'logo', targeting: {"tags":"sports","slot":"logo","pos":"logo"} });
			</script></div>		
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcmiami.com/tag/steph-curry/">Steph Curry</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard	</h1>
			<h2 class="article-subtitle">
			The Warriors guard and reigning NBA Finals MVP might not be the league's top overall player but Steph Curry was named the player that executives would want taking a shot with the game on the line		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Tom Dierberger							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-10-04T23:50:25-04:00">Published October 4, 2022</time>						<span class="meta-dot">&bull;</span>
					<time class="entry-date updated" datetime="2022-10-05T09:38:15-04:00">Updated 1 hour ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F&#038;Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard?_osource=db_npd_nbc_wtvj_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard&#038;url=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F?_osource=db_npd_nbc_wtvj_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F?_osource=db_npd_nbc_wtvj_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:1:7448666&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:12538,&quot;nbc_primary_tag_id&quot;:165,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;11&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:1:12538&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;rsn_disable_insider&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS\/692\/271\/18866126338.dfxp&quot;,&quot;mp4_url&quot;:&quot;&quot;,&quot;mpx_download_pid&quot;:&quot;17uVly4ZvxgF&quot;,&quot;mpx_download_pid_high&quot;:&quot;q8YS3hSvN2mN&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;PE8VDNDc0IH2&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcmiami.com\/2022\/10\/18866126338-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;ffT64Nuq_GWB&quot;,&quot;pid_streaming_web_medium&quot;:&quot;PE8VDNDc0IH2&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NBCU LM VMS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;2080562755747_649&quot;,&quot;video_length&quot;:&quot;71071&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_2080562755747&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="NBA Finals Odds For 2022-23 Season"
	data-vidcid="1:10:2875328"
	data-vidurl="https://www.nbcmiami.com/news/sports/nba-finals-odds-for-the-2022-23-season/2875328/"
			data-islead="true"
		data-catnames="{&quot;445300&quot;:&quot;News&quot;,&quot;434&quot;:&quot;Sports&quot;}"
	data-tagnames="{&quot;5280&quot;:&quot;Boston Celtics&quot;,&quot;2381&quot;:&quot;Golden State Warriors&quot;,&quot;165&quot;:&quot;NBA&quot;,&quot;616971&quot;:&quot;NBA basketball&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBC Universal, Inc.</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;According to PointsBet, here are the top 10 teams with the best chance of making the NBA Finals for the 2022-23 season as of Monday, Oct. 3.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
									<div class="article-content rich-text">
									
					
<p><em><a href="https://www.nbcsports.com/bayarea/warriors/steph-curry-dominates-nba-gm-survey-most-clutch-player-best-guard?cid=Yahoo&amp;partner=ya4nbcs&amp;chrcontext=WTVJ">Steph dominates GM survey, named NBA's most clutch player</a> originally appeared on <a href="https://www.nbcsports.com/bayarea?cid=MSN&amp;chrcontext=WTVJ">NBC Sports Bayarea</a></em></p>

<p>It's late in the fourth quarter with the game on the line. The clock is winding down. A big shot is needed.</p>

<p>Who would NBA general managers pick to take that shot?</p>

<p>That's right. Warriors superstar Steph Curry.</p>
<div class="mobile-app-promotion">
	
<blockquote class="featured-text">
	<em>Stay informed about local news and weather during the hurricane season. Get the NBC 6 South Florida app for </em><strong><em><a href="https://apps.apple.com/us/app/nbc-6/id331807842">iOS</a><em> or </em><a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcmiami.android&amp;hl=en_US">Android</a></em></strong> and pick your alerts<em>. </em></blockquote>
</div>

<p>In the <a data-timestamp="1664927640" href="https://www.nba.com/news/2022-23-gm-survey">annual survey taken by GMs</a> around the league, Curry was named the player that executives would want taking a shot with the game on the line. He won the category in a landslide.</p>

<p>Curry received 55 percent of the vote, far ahead of Kevin Durant (17 percent) in second place and Damian Lillard (14 percent) in third.</p>

<p>Last year, Durant won the category with a 41 percent vote. But in the 2021-22 NBA season, Curry took his clutch game to another level.</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Sports</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module"
						data-lid="Here&#039;s When Each Wild Card Baseball Game Starts and How to Watch Every Game This Weekend"						href="https://www.nbcmiami.com/news/sports/heres-when-each-wild-card-baseball-game-starts-and-how-to-watch-every-game-this-weekend/2875737/">
														<img alt="" class="post__image" srcset="https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&amp;strip=all&amp;fit=1600%2C900&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.nbcmiami.com/2022/10/web-100522-cardinalsphillieswildcard.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="MLB" class="post__tag" href="https://www.nbcmiami.com/tag/mlb/">MLB</a>
																			<span class="post__date post__date--has-category">
								<time class="entry-date published" datetime="2022-10-05T13:38:00+00:00">1 hour ago</time>							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Here&#039;s When Each Wild Card Baseball Game Starts and How to Watch Every Game This Weekend" class="post__title--link" href="https://www.nbcmiami.com/news/sports/heres-when-each-wild-card-baseball-game-starts-and-how-to-watch-every-game-this-weekend/2875737/">
								Here&#039;s When Each Wild Card Baseball Game Starts and How to Watch Every Game This Weekend							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module"
						data-lid="Fan Who Caught Aaron Judge&#039;s HR Ball Is Unsure What He&#039;ll Do With It"						href="https://www.nbcmiami.com/news/sports/this-is-my-husband-wife-outs-man-who-caught-aaron-judges-62nd-home-run/2875705/">
														<img alt="" class="post__image" srcset="https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=130&amp;h=73&amp;crop=1 130w, https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=170&amp;h=96&amp;crop=1 170w, https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=210&amp;h=118&amp;crop=1 210w, https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=250&amp;h=141&amp;crop=1 250w, https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=290&amp;h=163&amp;crop=1 290w, https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&amp;strip=all&amp;fit=1200%2C856&amp;w=330&amp;h=186&amp;crop=1 330w" src="https://media.nbcmiami.com/2019/09/GettyImages-993135956_master.jpg?quality=85&#038;strip=all" loading="lazy" sizes="(min-width: 768px) 166px, 124px" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="MLB" class="post__tag" href="https://www.nbcmiami.com/tag/mlb/">MLB</a>
																			<span class="post__date post__date--has-category">
								<time class="entry-date published" datetime="2022-10-05T10:51:46+00:00">4 hours ago</time>							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Fan Who Caught Aaron Judge&#039;s HR Ball Is Unsure What He&#039;ll Do With It" class="post__title--link" href="https://www.nbcmiami.com/news/sports/this-is-my-husband-wife-outs-man-who-caught-aaron-judges-62nd-home-run/2875705/">
								Fan Who Caught Aaron Judge&#039;s HR Ball Is Unsure What He&#039;ll Do With It							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>On Jan. 21, Curry swished a step-back jump shot as time expired to give the Warriors a 105-103 victory over the Houston Rockets. He had hit many clutch shots over the years, but that was his first legitimate buzzer beater.</p>

<figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">STEPH FOR THE WIN!!!! 😱 <a href="https://t.co/CF5BWeUkwT">pic.twitter.com/CF5BWeUkwT</a></p>&mdash; Warriors on NBCS (@NBCSWarriors) <a href="https://twitter.com/NBCSWarriors/status/1484761189326413824?ref_src=twsrc%5Etfw">January 22, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p>Curry brought a basket full of dagger shots to the Warriors' championship run, each properly celebrated by the "night night" celebration that c<a data-timestamp="1664927698" href="https://www.nbcsports.com/bayarea/warriors/andrew-mccutchen-epically-joins-night-night-steph-curry-celebration-trend?chrcontext=WTVJ">ountless athletes recently have adopted</a>.</p>

<p>Elsewhere in the survey, Curry was also named the best point guard in the NBA (72 percent), the best pure shooter in the league (91 percent), the best player at moving without the ball (81 percent) and the player that forces opposing coaches to make the most adjustments (52 percent).</p>
<div data-react-component="VideoPlayer" data-meta="{&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:1:7429865&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:12538,&quot;nbc_primary_tag_id&quot;:279,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;8&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:1:12538&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;rsn_disable_insider&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS\/993\/775\/18740866115.dfxp&quot;,&quot;mp4_url&quot;:&quot;&quot;,&quot;mpx_download_pid&quot;:&quot;idSDL18pwE_1&quot;,&quot;mpx_download_pid_high&quot;:&quot;NB8tCWPsbXWW&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;GD1kxH6B63Yk&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcmiami.com\/2022\/09\/18740866115-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;Td81K_p1EPG8&quot;,&quot;pid_streaming_web_medium&quot;:&quot;GD1kxH6B63Yk&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NBCU LM VMS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;2077657667726_192&quot;,&quot;video_length&quot;:&quot;131131&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_2077657667726&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}" data-livestream="false" data-title="2022 NBA Offseason Recap" data-vidcid="1:4:3014443" data-vidurl="https://www.nbcbayarea.com/news/sports/2022-nba-offseason-recap/3014443/" data-islead="false" data-catnames="{&quot;245076&quot;:&quot;News&quot;,&quot;434&quot;:&quot;Sports&quot;}" data-tagnames="{&quot;279&quot;:&quot;NBA&quot;,&quot;417629&quot;:&quot;NBA basketball&quot;}" data-customdata="{}" data-autoplay="false" data-cplay="true"></div>
<div class="video_caption" data-react-component="NBCTruncate" data-maxlines="2" data-maxlinesmobile="4" data-readmore="Read more" data-text="With the NBA season quickly approaching, here’s a recap of the biggest headlines from the 2022 offseason." data-ellipsis="false">
							With the NBA season quickly approaching, here’s a recap of the biggest headlines from the 2022 offseason.
						</div>
<p>The Warriors, by the way, were the second-most popular pick to win the 2023 NBA Finals. Golden State received 25 percent of the vote to repeat as champions, narrowly ahead of the Los Angeles Clippers (21 percent) and trailing only Giannis Antetokounmpo's Milwaukee Bucks (43 percent).</p>

<p>As Golden State attempts its second championship repeat in franchise history, it'll have the NBA's most clutch player leading the charge.</p>

									</div>
											<div class="article-copyright">Copyright RSN</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcmiami.com/tag/steph-curry/">Steph Curry</a><a class="article-tags__tag" href="https://www.nbcmiami.com/tag/nba/">NBA</a><a class="article-tags__tag" href="https://www.nbcmiami.com/tag/golden-state-warriors/">Golden State Warriors</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F&#038;Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard?_osource=db_npd_nbc_wtvj_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard&#038;url=https%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F?_osource=db_npd_nbc_wtvj_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Steph%20Curry%20Dominates%20NBA%20GM%20Survey%20for%20Most%20Clutch%20Player%2C%20Best%20Guard%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcmiami.com%2Fnews%2Fsports%2Fsteph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard%2F2875720%2F?_osource=db_npd_nbc_wtvj_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>		<div>
			<div id="taboola-below-article-thumbnails"></div>
		<script type="text/javascript">
			if (document.cookie.indexOf("scroll0=") < 0) {
				window._taboola = window._taboola || [];
				_taboola.push({
					article: 'auto',
					url: ''
				});
								_taboola.push({
					mode: 'thumbnails-a',
					container: 'taboola-below-article-thumbnails',
					placement: 'Below Article Thumbnails',
					target_type: 'mix'
				});
								_taboola.push({
					flush: true
				});
			};
		</script>
				<div id="mobile-native-below-article"></div>
		<script type="text/javascript">
			var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
			/** scroll cookie for scroll.com **/
			if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
				window._taboola = window._taboola || [];
				_taboola.push({
					mode: 'thumbs-feed-03-mobile',
					container: 'mobile-native-below-article',
					placement: 'Below Article Thumbnails - Fallback',
					target_type: 'text'
				});
			};
		</script>
			</div><!-- .taboola-container -->
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular">		<div class="most-popular__container">
			<div class="most-popular__header">
				<h3 class="widget-title">Trending Stories</h3>
				<div class="sponsored-ad-container">
					<div id="div-gpt-ad-logo_trending" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_trending', format: 'logo', targeting: {"slot":"logo","pos":"logo"} });
			</script>				</div>
			</div>
			<ul class="most-popular__posts-list">
									<li class="most-popular__post">
						<div class="post__image__wrap">
														<a
								data-lpos="most-popular"
								data-lid="WATCH VIDEO: Police Chase Through Broward Ends With 2 in Custody"
								href="https://www.nbcmiami.com/news/local/watch-video-police-chase-through-broward-ends-with-2-in-custody/2874927/"
							>
								<img
									class="post__image"
									src="https://media.nbcmiami.com/2022/10/100422-sunrise-police-chase.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="WATCH VIDEO: Police Chase Through Broward Ends With 2 in Custody"
									loading="lazy"
								/>
							</a>
													</div>

						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="Broward"
										href="https://www.nbcmiami.com/tag/broward/"
									>
										Broward									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="WATCH VIDEO: Police Chase Through Broward Ends With 2 in Custody"
									href="https://www.nbcmiami.com/news/local/watch-video-police-chase-through-broward-ends-with-2-in-custody/2874927/"
								>
									WATCH VIDEO: Police Chase Through Broward Ends With 2 in Custody								</a>
							</div>
													</div>
					</li>
									<li class="most-popular__post">
						<div class="post__image__wrap">
														<a
								data-lpos="most-popular"
								data-lid="Fort Lauderdale Police Find Missing 11-Year-Old Girl"
								href="https://www.nbcmiami.com/news/local/fort-lauderdale-police-find-missing-11-year-old-girl/2875731/"
							>
								<img
									class="post__image"
									src="https://media.nbcmiami.com/2021/04/040421-fort-lauderdale-police-car.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="Fort Lauderdale Police Find Missing 11-Year-Old Girl"
									loading="lazy"
								/>
							</a>
													</div>

						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="Fort Lauderdale"
										href="https://www.nbcmiami.com/tag/fort-lauderdale/"
									>
										Fort Lauderdale									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Fort Lauderdale Police Find Missing 11-Year-Old Girl"
									href="https://www.nbcmiami.com/news/local/fort-lauderdale-police-find-missing-11-year-old-girl/2875731/"
								>
									Fort Lauderdale Police Find Missing 11-Year-Old Girl								</a>
							</div>
													</div>
					</li>
									<li class="most-popular__post">
						<div class="post__image__wrap">
														<a
								data-lpos="most-popular"
								data-lid="Man Fatally Struck by Pickup Truck in Fontainebleau: FHP"
								href="https://www.nbcmiami.com/news/local/man-fatally-struck-by-pickup-truck-in-fontainebleau-fhp/2875663/"
							>
								<img
									class="post__image"
									src="https://media.nbcmiami.com/2022/10/Screen-Shot-2022-10-05-at-7.33.53-AM.png?resize=100%2C56&#038;quality=85&#038;strip=all"
									alt="Man Fatally Struck by Pickup Truck in Fontainebleau: FHP"
									loading="lazy"
								/>
							</a>
													</div>

						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="nw miami-dade"
										href="https://www.nbcmiami.com/tag/nw-miami-dade-2/"
									>
										nw miami-dade									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Man Fatally Struck by Pickup Truck in Fontainebleau: FHP"
									href="https://www.nbcmiami.com/news/local/man-fatally-struck-by-pickup-truck-in-fontainebleau-fhp/2875663/"
								>
									Man Fatally Struck by Pickup Truck in Fontainebleau: FHP								</a>
							</div>
													</div>
					</li>
									<li class="most-popular__post">
						<div class="post__image__wrap">
														<a
								data-lpos="most-popular"
								data-lid="Actor Pablo Lyle Found Guilty of Manslaughter in Miami Road Rage Case"
								href="https://www.nbcmiami.com/news/local/pablo-lyle-manslaughter-trial/2874770/"
							>
								<img
									class="post__image"
									src="https://media.nbcmiami.com/2022/10/100422-Pablo-Lyle.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
									alt="Actor Pablo Lyle Found Guilty of Manslaughter in Miami Road Rage Case"
									loading="lazy"
								/>
							</a>
													</div>

						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="Miami"
										href="https://www.nbcmiami.com/tag/miami/"
									>
										Miami									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="Actor Pablo Lyle Found Guilty of Manslaughter in Miami Road Rage Case"
									href="https://www.nbcmiami.com/news/local/pablo-lyle-manslaughter-trial/2874770/"
								>
									Actor Pablo Lyle Found Guilty of Manslaughter in Miami Road Rage Case								</a>
							</div>
													</div>
					</li>
									<li class="most-popular__post">
						<div class="post__image__wrap">
														<a
								data-lpos="most-popular"
								data-lid="List: Here&#039;s What You Can Donate to Help Ian Victims in Southwest Florida"
								href="https://www.nbcmiami.com/news/local/list-heres-what-you-can-donate-to-help-ian-victims-in-southwest-florida/2872467/"
							>
								<img
									class="post__image"
									src="https://media.nbcmiami.com/2022/09/GEM-hurricane-ian-help-09302022.png?resize=100%2C56&#038;quality=85&#038;strip=all"
									alt="List: Here&#039;s What You Can Donate to Help Ian Victims in Southwest Florida"
									loading="lazy"
								/>
							</a>
													</div>

						<div class="post__content">
															<h4 class="post__category">
									<a
										class="post__category-link"
										data-lpos="most-popular"
										data-lid="How to Help"
										href="https://www.nbcmiami.com/tag/how-to-help/"
									>
										How to Help									</a>
								</h4>
														<div class="post__title">
								<a
									class="post__category-link"
									data-lpos="most-popular"
									data-lid="List: Here&#039;s What You Can Donate to Help Ian Victims in Southwest Florida"
									href="https://www.nbcmiami.com/news/local/list-heres-what-you-can-donate-to-help-ian-victims-in-southwest-florida/2872467/"
								>
									List: Here&#039;s What You Can Donate to Help Ian Victims in Southwest Florida								</a>
							</div>
													</div>
					</li>
													<li class="most-popular__post taboola__post">
						<div id="taboola-right-rail-thumbnails---fallback"></div>
					</li>
					<script>
						try {
							window._taboola = window._taboola || [];
							_taboola.push({
								listenTo: 'nocontent',
								placement: 'Right Rail Thumbnails - Fallback',
								handle: function() {
									document.querySelector('.most-popular__post:nth-of-type(5)').remove();
								}
							});
							_taboola.push({
								mode: 'thumbnails-a-right-rail',
								container: 'taboola-right-rail-thumbnails---fallback',
								placement: 'Right Rail Thumbnails - Fallback',
								target_type: 'mix',
								flush: true,
							});
						} catch (e) {
							console.error(e);
						}
					</script>
							</ul>
		</div>
		</section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_843" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_843', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Miami, FL"></div>
	<a class="weather-module__conditions" href="https://www.nbcmiami.com/weather/">
		<div data-react-component="IframeConditions" data-location="33133"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_554" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_554', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-7" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_601" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_601', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_180" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_180', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-14" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_593" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_593', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="WTVJ_BreakingNews"
				data-footer-signup=""
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="0d1db992f3"
				data-show-terms-box=""
				data-use-newsletter-ids=""
				data-newsletter-ids="[]"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcmiami.com/" class="site-footer__logo">
					<img
						src="https://media.nbcmiami.com/2019/09/South_Florida_On_Light@3x.png?fit=627%2C120&#038;quality=85&#038;strip=all"
						alt="NBC 6 South Florida"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/NBC6SouthFlorida" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbc6" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbc6" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2143522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2143522"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2122474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2122474"><a href="https://www.nbcmiami.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2143183" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2143183"><a href="https://www.nbcmiami.com/contact-us/">Contact Us</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1936527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1936527"><a href="https://publicfiles.fcc.gov/tv-profile/WTVJ">WTVJ Public Inspection File</a></li>
<li id="menu-item-2795256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2795256"><a href="https://www.nbcmiami.com/wtvj-accessibility/">WTVJ Accessibility</a></li>
<li id="menu-item-1936574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1936574"><a href="https://www.nbcmiami.com/wtvj-employment-information/">WTVJ Employment Information</a></li>
<li id="menu-item-2313874" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2313874"><a href="https://www.nbcmiami.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1936573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1936573"><a href="https://www.nbcmiami.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1936540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1936540"><a href="https://together.nbcuni.com/advertise/?utm_source=nbcmiami&#038;utm_medium=referral&#038;utm_campaign=property_ad_pages">Advertise with us</a></li>
<li id="menu-item-1936572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1936572"><a href="https://www.nbcmiami.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-1936528" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1936528"><a target="_blank" rel="noopener" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_South_Miami">Privacy Policy</a></li>
<li id="menu-item-2122369" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2122369"><a id="ot-sdk-btn" class="ot-sdk-show-settings">Cookie Settings</a></li>
<li id="menu-item-2265809" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2265809"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_South_Miami">CA Notice</a></li>
<li id="menu-item-1936539" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1936539"><a target="_blank" rel="noopener" href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">Ad Choices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

			<script
				src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js"
				id="privacyCookie"
				type="text/javascript"
				charset="UTF-8"
				ccpa-opt-out-ids="dummy"
				ccpa-opt-out-geo="US"
				ccpa-opt-out-lspa="false"
			>
			</script>
			<script
				src="https://cdn.cookielaw.org/consent/8b8e9bc7-b84a-402b-a11e-332a66419d66/otSDKStub.js"
				data-document-language="true"
				type="text/javascript"
				charset="UTF-8"
				data-domain-script="8b8e9bc7-b84a-402b-a11e-332a66419d66"
									integrity="sha384-ZiegGStHtw2zXX+Hd9IX8tTxIDTMb8FwlLNdjP0V2aK9ddQu9SYkgu3Q0U+t6ZgN"
					crossorigin="anonymous"
							>
			</script>
				<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcmiami.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "news, sports";
		_sf_async_config.authors  = "Tom Dierberger";
		_sf_async_config.title    = "Steph Curry Dominates NBA GM Survey for Most Clutch Player, Best Guard";
		_sf_async_config.path     = "nbcmiami.com\/news\/sports\/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard\/2875720\/";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2875720' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wtvj\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcmiami.com/news/sports/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard/2875720/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcmiami.com/">
					<img
						src="https://media.nbcmiami.com/2019/09/South_Florida_On_Light@3x.png?fit=627%2C120&#038;quality=85&#038;strip=all"
						alt="NBC 6 South Florida"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcmiami.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input class="search-form-input" type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="News" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/">
					News				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="US &amp; World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					US &amp; World				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Weather alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather alerts				</a>
							<a data-lid="Hurricane Season" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/hurricane-season/">
					Hurricane Season				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/responds/">
					Responds				</a>
							<a data-lid="Submit a tip" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a tip				</a>
							<a data-lid="Impact With Jackie Nespral" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/politics/impact/">
					Impact With Jackie Nespral				</a>
							<a data-lid="LX News" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lxnews/">
					LX News				</a>
							<a data-lid="6 In The Mix" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/6-in-the-mix/">
					6 In The Mix				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Latin Beat" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/latin-beat/">
					Latin Beat				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Community" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/community/">
					Community				</a>
							<a data-lid="TV Listings" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="http://nbcmiami.com/live/">
					TV Listings				</a>
							<a data-lid="Contests" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/on-air/contests/">
					Contests				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Submit a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcmiami.com/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Contests" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcmiami.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/NBC6SouthFlorida" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbc6" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbc6" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us/"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcmiami.com/_static/??-eJydkDtuwzAQRC8U8yOuSKoIUqdJ69JY7ZIxAYk0RDqCbx/aJ0hUbbEzD4Mn99uJSm4hN9muYQ1V5plOtWFLJUta0vMz39PCkmqVsWxrFYrsxHHGCODQDKhncGJNWfTIm/wnMoe9LqG1sJ0Tf4cmAAmY2GEYOtp5GtEcpsdSOlkMfbEfIPLoYgQ2WrnxOHN5lHv7wh8xUd/q0HqDREbPw+j1YewesMe2z97pigHZq2iZ/Qjaqcjmz4pfl17M24KPsF3q2jVcn92P9V1bC5PXCtwvlv20fw==' type='text/css' media='all' />
<script src='https://www.nbcmiami.com/wp-content/mu-plugins/jetpack-10.9/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script defer src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/hooks.min.js?ver=a7edae857aab69d69fa10d5aef23a5de' id='wp-hooks-js'></script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/url.min.js?ver=9e623834b7667b522230408f099fc05f' id='wp-url-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcmiami.com/wp-includes/js/dist/api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/common.777b8c50ee5981288a50.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/global.31cc2e372e4678b78bc6.bundle.min.js?ver=1.0.2' id='nbc-global-js'></script>
<script async src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/article.0c27adc40deacaaf351a.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script defer src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<script defer src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.41361bee6a87fc480579.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script defer src='https://native.sharethrough.com/assets/sfp.js?ver=5.8.5' id='sharethrough-js'></script>
<script async src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.ac61e73253c83f950d66.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/articleContent.3509075b7997136942e0.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script async src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.fe03c99fac160493faa2.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://www.nbcmiami.com/wp-includes/js/wp-embed.min.js?ver=5.8.5' id='wp-embed-js'></script>
<script src='https://www.nbcmiami.com/wp-content/themes/nbc-station/client/build/js/newsletterWidget.1760885c79cb6f8e7cbf.bundle.min.js?ver=1.0.2' id='newsletter-widget-js'></script>
<script src='https://stats.wp.com/e-202240.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'165596159',post:'2875720',tz:'-4',srv:'www.nbcmiami.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '165596159', '2875720' ]);
</script>
	<script>
	(function(b,r,a,n,c,h,_,s,d,k){if(!b[n]||!b[n]._q){for(;s<_.length;)c(h,_[s++]);d=r.createElement(a);d.async=1;d.src="https://cdn.branch.io/branch-latest.min.js";k=r.getElementsByTagName(a)[0];k.parentNode.insertBefore(d,k);b[n]=h}})(window,document,"script","branch",function(b,r){b[r]=function(){b._q.push([r,arguments])}},{_q:[],_v:1},"addListener applyCode autoAppIndex banner closeBanner closeJourney creditHistory credits data deepview deepviewCta first getCode init link logout redeem referrals removeListener sendSMS setBranchViewData setIdentity track validateCode trackCommerceEvent logEvent disableTracking".split(" "), 0);
	branch.init(
		decodeURIComponent('key_live_hl1G1ttqMQewtG9drqHZ2cmnFCoKCG4Z'),
		{"no_journeys":false}	);
		branch.setBranchViewData({
		data: {
			'$desktop_url': 'https://www.nbcmiami.com/news/sports/steph-curry-dominates-nba-gm-survey-for-most-clutch-player-best-guard/2875720/'
		}
	});
		</script>
	
</body>
</html>
